토마토
시간 | 제한메모리 | 제출 | 정답 | 맞힌 사람 | 정답 비율 |
1 초 | 256 MB | 108918 | 39112 | 24578 | 34.428% |
문제
철수의 토마토 농장에서는 토마토를 보관하는 큰 창고를 가지고 있다. 토마토는 아래의 그림과 같이 격자모양 상자의 칸에 하나씩 넣은 다음, 상자들을 수직으로 쌓아 올려서 창고에 보관한다.
창고에 보관되는 토마토들 중에는 잘 익은 것도 있지만, 아직 익지 않은 토마토들도 있을 수 있다. 보관 후 하루가 지나면, 익은 토마토들의 인접한 곳에 있는 익지 않은 토마토들은 익은 토마토의 영향을 받아 익게 된다. 하나의 토마토에 인접한 곳은 위, 아래, 왼쪽, 오른쪽, 앞, 뒤 여섯 방향에 있는 토마토를 의미한다. 대각선 방향에 있는 토마토들에게는 영향을 주지 못하며, 토마토가 혼자 저절로 익는 경우는 없다고 가정한다. 철수는 창고에 보관된 토마토들이 며칠이 지나면 다 익게 되는지 그 최소 일수를 알고 싶어 한다.
토마토를 창고에 보관하는 격자모양의 상자들의 크기와 익은 토마토들과 익지 않은 토마토들의 정보가 주어졌을 때, 며칠이 지나면 토마토들이 모두 익는지, 그 최소 일수를 구하는 프로그램을 작성하라. 단, 상자의 일부 칸에는 토마토가 들어있지 않을 수도 있다.
입력
첫 줄에는 상자의 크기를 나타내는 두 정수 M,N과 쌓아올려지는 상자의 수를 나타내는 H가 주어진다. M은 상자의 가로 칸의 수, N은 상자의 세로 칸의 수를 나타낸다. 단, 2 ≤ M ≤ 100, 2 ≤ N ≤ 100, 1 ≤ H ≤ 100 이다. 둘째 줄부터는 가장 밑의 상자부터 가장 위의 상자까지에 저장된 토마토들의 정보가 주어진다. 즉, 둘째 줄부터 N개의 줄에는 하나의 상자에 담긴 토마토의 정보가 주어진다. 각 줄에는 상자 가로줄에 들어있는 토마토들의 상태가 M개의 정수로 주어진다. 정수 1은 익은 토마토, 정수 0 은 익지 않은 토마토, 정수 -1은 토마토가 들어있지 않은 칸을 나타낸다. 이러한 N개의 줄이 H번 반복하여 주어진다.
토마토가 하나 이상 있는 경우만 입력으로 주어진다.
출력
여러분은 토마토가 모두 익을 때까지 최소 며칠이 걸리는지를 계산해서 출력해야 한다. 만약, 저장될 때부터 모든 토마토가 익어있는 상태이면 0을 출력해야 하고, 토마토가 모두 익지는 못하는 상황이면 -1을 출력해야 한다.
예제 입력 1
5 3 1
0 -1 0 0 0
-1 -1 0 1 1
0 0 0 1 1
예제 출력 1
-1
예제 입력 2
5 3 2
0 0 0 0 0
0 0 0 0 0
0 0 0 0 0
0 0 0 0 0
0 0 1 0 0
0 0 0 0 0
예제 출력 2
4
(나머지 예제 생략)
풀이
import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.*;
import java.util.function.IntUnaryOperator;
import java.util.stream.Collectors;
import java.util.stream.IntStream;
import java.util.stream.Stream;
@BOJ( number = 7569,
tier = BaekjoonTier.GOLD_V,
solveDate = @SolveDate(year = 2022, month = 2, day = 8))
public class 백준7569 {
public static void main(String[] args) throws Exception {
Store<Tomato> tomatoStore = setInputAndGetStore();
System.out.println(tomatoStore.getAllRipeDay());
}
public static Store<Tomato> setInputAndGetStore() throws Exception{
try (BufferedReader br = new BufferedReader(new InputStreamReader(System.in))) {
int[] ints = Arrays.stream(br.readLine().split(" ")).mapToInt(Integer::parseInt).toArray();
int x = ints[0];//가로 col
int y = ints[1];//세로 row
int z = ints[2];
ArrayList<ArrayList<ArrayList<Tomato>>> store = new ArrayList<>();
for (int i = 0; i < z; i++) {
store.add(new ArrayList<>());
for (int j = 0; j < y; j++) {
store.get(i).add(new ArrayList<>());
String[] str = br.readLine().split(" ");
for (int k = 0; k < x; k++) {
store.get(i).get(j).add(Tomato.parseTomato(str[k], k, j, i));
}
}
}
return new Store<Tomato>(store, x, y, z);
}
}
private static class Store<T extends Tomato> {
private ArrayList<ArrayList<ArrayList<T>>> store = new ArrayList<>(new ArrayList<>());
private final int X_SIZE;
private final int Y_SIZE;
private final int Z_SIZE;
public Store (ArrayList<ArrayList<ArrayList<T>>> store, int x_SIZE, int y_SIZE, int z_SIZE) {
this.store = store;
X_SIZE = x_SIZE;
Y_SIZE = y_SIZE;
Z_SIZE = z_SIZE;
}
public int getAllRipeDay(){
Deque<T> deque = new ArrayDeque<>();
IntStream.range(0, Z_SIZE).forEach(z -> {
IntStream.range(0, Y_SIZE).forEach(y ->{
IntStream.range(0, X_SIZE).forEach(x ->{
T t = store.get(z).get(y).get(x);
if( t != null && t.isRiped()) {
deque.offer(store.get(z).get(y).get(x));
}
});
});
});
riping(deque);
int max = 0;
for (ArrayList<ArrayList<T>> box : store) {
for (ArrayList<T> line : box) {
for (T t : line) {
if(t == null) continue;
if(!t.isRiped())return -1;
if(t.getRipeDay() > max){
max = t.getRipeDay();
}
}
}
}
return max;
}
private void riping(Deque<T> deque) {
while (!deque.isEmpty()){
T current = deque.poll();
current.getAroundPosition().stream().filter(this::isMovable)
.map(this::getOptByPosition)
.filter(Optional::isPresent)
.map(Optional::get)
.filter(t1 -> !t1.isRiped())
.forEach(toBe -> setRipeDayAndEnque(current, toBe, deque));
}
}
private int plusOne(int i) {
return ++i;
}
private boolean isMovable(Position position){
int x = position.getX();
int y = position.getY();
int z = position.getZ();
return (x > -1) && (y > -1) && (z > -1) &&
(z < Z_SIZE) &&
(y < Y_SIZE) &&
(x < X_SIZE);
}
private Optional<T> getOptByPosition(Position position){
return Optional.ofNullable(store.get(position.getZ()).get(position.getY()).get(position.getX()));
}
private void setRipeDayAndEnque(T isAs, T toBe, Deque<T> deque){
toBe.riping();
toBe.setRipeDay(isAs.getRipeDay() + 1);
deque.offer(toBe);
}
}
private static class Tomato implements Comparable<Tomato>{
private Position position;
private boolean isRiped;
private int ripeDay;
private Tomato(Position position) {
this.position = position;
}
public static Tomato fromRiped(Position position){
Tomato tomato = new Tomato(position);
tomato.riping();
return tomato;
}
public static Tomato fromNoneRiped(Position position){
return new Tomato(position);
}
public Position getPosition() {
return position;
}
public boolean isRiped() {
return isRiped;
}
public int getRipeDay() {
return ripeDay;
}
public void riping() {
isRiped = true;
}
public void setRipeDay(int ripeDay) {
this.ripeDay = ripeDay;
}
public List<Position> getAroundPosition(){
List<Position> result = new ArrayList<>();
int currentX = position.getX();
int currentY = position.getY();
int currentZ = position.getZ();
result.add(Position.of(currentX+1,currentY,currentZ));
result.add(Position.of(currentX-1,currentY,currentZ));
result.add(Position.of(currentX,currentY+1,currentZ));
result.add(Position.of(currentX,currentY-1,currentZ));
result.add(Position.of(currentX,currentY,currentZ+1));
result.add(Position.of(currentX,currentY,currentZ-1));
return result;
}
@Override
public int compareTo(Tomato o) {
return ripeDay - o.getRipeDay();
}
public static Tomato parseTomato(String str, int x, int y, int z) {
return switch (str){
case "1" -> Tomato.fromRiped(Position.of(x,y,z));
case "0" -> Tomato.fromNoneRiped(Position.of(x,y,z));
default -> null;
};
}
}
private static class Position {
private int x;
private int y;
private int z;
private Position(int x, int y, int z) {
this.x = x;
this.y = y;
this.z = z;
}
private static Position of(int x, int y, int z){
return new Position(x, y, z);
}
public int getX() {
return x;
}
public int getY() {
return y;
}
public int getZ() {
return z;
}
}
}
'Algorithm > 백준' 카테고리의 다른 글
[백준/7562/Java] 나이트의 이동 (0) | 2022.02.10 |
---|---|
[백준/1697/Java] 숨바꼭질 (0) | 2022.02.09 |
[백준/2178/Java] 미로 탐색 (0) | 2022.02.07 |
[백준/7576/Java] 토마토 (0) | 2022.02.07 |
[백준/1012/Java] 유기농 배추 (0) | 2022.02.05 |